
 

  
Release Notes
This document contains release notes which explain modifications and changes between EnSight releases.  
This document is only useful if you are a current EnSight user and have upgraded to a new version of 
EnSight.  New users need not view these notes.

Index:
Release notes from EnSight 8.2 to EnSight 9.0
Release notes from EnSight 8.0 to EnSight 8.2

Release notes from EnSight 8.2 to EnSight 9.0
Index
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Documentation
Framework Changes
GUI Changes
Interaction
Support tool
New and Modified Features
APIs and Data Formats
Compatibilities
Other Components

Installation

EnSight 9.0 will install itself under $CEI_HOME/ensight90/ and will not modify any files previously 
installed with earlier versions.  EnSight can be launched from the desktop icons or by running "ensight90" 
from a command-line.

Licensing

EnSight 9.0 uses the same SLiM 8.x license manager and same license keys as 8.0 and 8.2.  No change to 
the licensing is necessary if you are currently running SLiM 8.x.

Documentation

The User, How-To, Command Language, and Getting Started manuals have all been updated to reflect 
changes in EnSight 9.0.

Framework Changes

EnSight 9.0 updates the core framework to Python 2.5.1 and Qt 4.4.1. This includes an update to PyQt4 for 
user-extensible interfaces.

GUI Changes

The main EnSight GUI should remain familiar to current users.  Notable updates:

The "Show Selected Parts" window is no longer supported, and has been replaced by the new part 
highlighting in the graphics window.  This functionality can be toggled on and off using the ‘S’ key macro 
or the highlight icon in the main GUI.

The Store/Recall view functionality has been replaced by a button to pop up the Views manager, from 
which you can save and restore multiple views with thumbnails.
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There is a new top-level menu called “Window” which contains actions related to the main GUI and 
auxiliary dialogs.  Some of the options under this menu allow you to toggle to a completely new user 
interface.

Interaction

Major ease-of-use enhancements have been made.  Interaction in the graphics window is significantly 
easier with the use of left-button-click to select objects and right-button-click to operate on objects.  Parts, 
Viewports, and Annotations can all be picked, and many attributes and operations are directly available in 
the right-click menus, such as creating a new clip plane or query over time.  The default click-actions are:

Left-click: Pick part.
Ctrl+Left-click: Keep current selection and toggle part under cursor.
Middle-click: Current pick operation (default pick part).
Right-click: Select part and open right-click menu.

Ctrl+Right-click: Keep current selection and open right-click menu.
Mouse click+drag operations remain the same.

Double-clicking in the graphics window is no longer supported and has no effect.

Additional direct-interaction techniques are implemented for certain part and annotation types.  For 
example, when you select an isosurface or clip plane, you will see a marker appear in the graphics window.  
Clicking on this marker will allow you to drag the mouse to change the isovalue or clip value.  Clicking on 
an annotation will allow you to move/resize the annotation without having to change to annotation mode.

Right-click is not supported in full-screen mode.

Support tool

There is now an integrated support tool which allows you to more quickly send a detailed request to 
EnSight support including relevant information about your EnSight session (platform, graphics card, etc).  
International customers can select their local distributor as the contact, and there is also an option to 
manually enter an e-mail address.

This dialog is available using the “Online Support...” option in the “Help” menu.  We hope that this will 
make it easier for you to more completely report your system state and your problem and for us to more 
quickly and completely understand the details and thus to reduce the time to resolution.

New and Modified Features

- Number of Parts: The limit of 5000 parts has been raised to 65000.

- Number of Variables: The limit of 300 variables has been raised to 10000.

- SoS MPI Support: MPI launch and communication is now supported for server-of-servers.  Contact CEI 
for information on this.

- Blanking enhancement: Added capability to blank both inside and outside for element blanking.  Also 
added ability to blank just the first visible layer  (8.x behavior) as well as blank all layers.

- Camera Fastened to Plane tool: Added ability for a camera to tie itself to the plane tool - ideal for viewing 
a 2d plane clip.

- Vector Arrow Default: Changed default for vector arrows to show cone type tips and a 0.4 proportional 
size.

- Camera on Node ID: Cameras that are tied to a node id (origin or direction) will transform in a flipbook 
playback.
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- Crinkly nfaced clip: Crinkly clips of nfaced elements will now produce nfaced results.

- Offscreen Rendering: Offscreen rendering of large images is now faster (on supported platforms)h.

- Multi-sampled visuals: By default we are no longer using a multi-sampled visual.  The reason for this is 
that several of the new interaction techniques will not work properly with multi-sampled visuals such as 
transparency sorting via depth peeling (which was available in 8.2 but was off by default), and hardware 
accelerated graphical part picking (you will still get software part picking if hardware accelerated is not 
available).  The loss of a multi-sampled visual results in loss of anti-aliased graphics, i.e., your lines and 
edges of polygons will appear more "jaggy" than they did before.
When saving images and animations, you can choose multi-pass output for smoothing of images.  This is 
independent of the graphics window setting.
In batch mode, the number of smoothing passes will be exactly as specified in your command file.  
Previous versions of EnSight used 4 passes in batch mode to match the default multi-sampling level of the 
interactive graphics window.
- Transparency: By default EnSight 9.0 uses depth peeling for transparency if available.

- Background color: The default viewport background color is a blended blue background.  This default 
can be changed in the Viewports section of the Edit>Preferences dialog.

- User Interface Color (under Linux): The user interface color is now controlled by your window manager 
settings.

- Full-screen mode on Linux now uses the window manager to position windows.  Full-screen behavior on 
multi-monitor systems will depend on your Desktop settings.

- Line vs. Shaded:  The default visual mode is now shaded.  This default can be changed in the View 
section of the Edit>Preferences dialog.
- Threading: EnSight 9.0 Client, Server and Server of Servers all have threading turned on according to the 
number of CPUs.  Compute-intensive Server operations (such as isosurface, clipping and particle tracing) 
are threaded, Graphics-intensive operations (such as display-list creation and transparency resort) are 
threaded, and the start up of the Servers by the Server of Servers is threaded.
APIs and Data Formats

The Python API to EnSight has been significantly enhanced, with a full object-oriented interface to Parts, 
Viewports, Annotations, and other objects.  You can explore the new API by executing "print 
dir(ensight.objs.core)" in the Python tab of the Command Dialog.  More details on this new API will be 
forthcoming.

The Python extensions mechanism has become more formalized, with base classes for Python Tools, 
Right-click menus, and GUIs.  Extensions have their own namespace and can extend the EnSight 
command language for journaling and playback.

A new user-defined reader API (version 3.0) is under development, which makes it much easier to develop 
new data interfaces for EnSight.  The new API allows for multi-block geometry, global or per-part 
coordinate arrays, and more.  You simply describe your data natively and we'll handle the rest.

A new EnSight output API is available for writing EnSight 6 and EnSight Gold files from your own code.  
The library C source code is available, and compiled libraries are provided for supported platforms.  There 
is also a Python wrapper distributed both in source code and compiled as a module for the included Python 
interpreter.

Compatibilities

Archives are NOT compatible between 8.2 and version 9.0
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Other Components
EnLiten remains essentially unchanged in look, feel, and functionality.

EnVideo 9.0 includes improved pan-n-zoom functionality.  The default position can be reset using the ‘R’ 
key.  In parallel rendering mode the cursor will automatically be hidden

Reveal 2.0 will hide the cursor in parallel rendering mode.
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Release notes from EnSight 8.0 to EnSight 8.2
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Other Components
Mac PDF Reader Issue

Installation
EnSight 8.2 will install itself under INSTALL_DIRECTORY/CEI/ensight82/ and will not modify any files 
previously installed with earlier versions.

By design, the ensight8, ensight8_client, ensight8_server, and ensight8_sos scripts in the bin directory will 
run the version of EnSight installed last (in this case 8.2).  If you wish to run older versions of EnSight, 
such as 8.0, you may do so by specifically running this version such as "ensight80".

Licensing
EnSight 8.2 uses the same SLiM license manager and same license keys as 8.0.  No change to the licensing 
is necessary if you are currently running 8.0.

Documentation
The User, How-To, Command Language, and Getting Started manuals have all been updated to reflect 
changes in 8.2.

Additionally, a new Interface Manual has been created. It eliminates a number of README files which 
were scattered in various locations, and contains the information needed for producing user-defined 
readers, producing user-defined writers, producing user-defined math functions, using the EnSight external 
command driver, and using the EnSight Python interpreter.

GUI Changes
A new User Defined icon is now visible in the feature icons.  This icon will pull up a user defined GUI as 
explained in the New and Modified Features section.  If no user defined elements are available the icon 
will not be shown.

Under the File pulldown the following changes have been made:

"Connect server..." has been removed.  The connection settings have now been moved to the Case 
pulldown.

"Open..." and "Data (reader)..." have been consolidated into a "Open..." option with a "Simple" and 
"Advanced" capability

"Record current animation..." has been moved to the File->Save options

The "Sort..." button immediately under the part list has been renamed "List..."  The List... pulldown 
contains several new options for tree list view - see the New and Modified Features section.

The Variable list found in the Feature Detail Editor for Variables and Calculator now shows the Case that a 
variable belongs to.

All of the detail editors now show all variables available in any variable chooser.  The variable will be 
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activated as needed.  In 8.0 the detail editors showed only the active variables.

In the Feature Detail Editor (Calculator) dialog all variables are now shown in the calculator section.  
EnSight now activates the variables as needed.

The Displacement icon in Part mode has been modified.

New icons have been added to Annot mode to reflect new capabilities.

The View->Static Lighting option has been removed

Up/Down arrows to control value fields have been added in several places such as particle trace animation 
controls and vector arrow scale factor.

The Print/Save Image dialog has been modified to show new options available for printing.

New and Modified Features

Connections Under the Case pulldown you will find two new options.

Connection details... brings up a dialog showing some information for the case 
selected such as amount of data transferred and what data is 
loaded.

Connection settings... pulls up a new dialog.  In this dialog you can switch your 
server or SoS connection to a different machine, save 
preferences for these machines and add/replace cases. This 
essentially allows you to change the connection settings after 
EnSight starts up (but before you read data).

Commands and 
Macros

The command dialog is all new.  If you play a command file you can now see the 
upcoming commands as well as the history.  You can also right click to set 
breakpoints as well as save/execute the selected commands.
A separate tab will allow you to see, modify, and define macros.
Another tab will allow you to execute Python scripts.

Part List The part list can be organized into different tree list views by List->Show Tree and 
selecting one of the options.  In 8.0 a parent/child tree list was available (still is).  In 
8.2 we add the ability to view in part tree mode part attributes such as visibility, line 
vs. shaded, etc.

Save Image 
Formats

EnSight 8.2 utilizes a user defined image library (UDIL). Incorporated into this 
image library is support for the following image/movie formats: AVI (raw, mpeg, 
mpg4), BMP, EVO, QuickTime (mpg4) Animated GIF, JPEG, PNG, PPM, XPM, 
SGI, LLNL SM, TIFF, MPEG1, MPEG2, MPEG4.  In addition, it is possible for the 
user to define his own formats which are seen by EnSight at run time.
Also changed with the UDIL support are options to save the images in stereo (even 
if you are not currently in stereo mode or are running on stereo capable hardware) 
render the images to an offscreen buffer, set the anti-aliasing quality settings, and 
render to arbitrary size images.

All platforms support the ability to copy the current window contents to the system 
native clipboard.
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User Defined 
Interface

It is possible to add your own user interface to EnSight in order to enhance the 
current GUI or you can replace the entire GUI with your own.  This is done through 
Python.  Several examples of this can be found in the 8.2 installation.

Right Click User 
Defined 
capabilities

It is possible to define a right click action.  Upon the right click action a custom user 
interface will pop up.  With this customer right click interface you can query what 
was selected at the time of the right click event and perform actions accordingly.  
For example, from your code you can find that a certain part number and certain 
node number was selected.  You could then query this node over time and plot the 
results.  Or have the ability to make the selected part invisible, etc.

Tools The quadric tools now have rotate handles.  The Transformation dialog has been 
modified to allow you to rotate these tools from the dialog. Given the quadric tools 
now have an axis system, they now translate in the tools axis system instead of 
transforming in the global coordinate system
The line tool now has rotate handles.  The Transformation dialog has been modified 
to allow you to rotate the line tool from this dialog. Given the line tool now has an 
axis system it now translates in the tools axis system instead of transforming in the 
global coordinate system.
The plane tool can now be defined by three node numbers.  As these node numbers 
move over time the plane tool will update.  The line tool has also been modified 
similarly, i.e., it can be defined by two node numbers.  The pick option has been 
extended to allow you to pick the line and plane tools via node numbers.

Clips The quadric clips can now be finite.
The line clips can be of type mesh or grid - previous versions of EnSight only did a 
uniform sampling (grid clip) for the line clip option.  A mesh line clip can be infinite 
or finite.  A line clip can also now be of type "Crinkly"
In/Out clips can now be finite for all tools.
A plane clip can be defined by three node numbers.  Over time the node numbers 
may move in which case the plane clip will update accordingly.
The line clip can be defined by two node numbers.  Over time the node numbers 
may move in which case the line clip will update accordingly.

Query The X/Y query as well as the Interactive query now show markers that update to 
new locations if you change timesteps.  The markers also update if the model is 
displaced.
In Interactive Query mode it is now possible to query the min/max values
In Interactive Query mode it is possible to "expand" the query out to show the 
neighboring nodes and elements.  You have control over the number of levels you 
wish to see.  The "expand" capability is done through the subset part capability and 
thus when you turn off the interactive query you will get a pop-up dialog asking if 
you want to save the subset part used by the query expansion.

Displacements The coordinates of Model parts can be modified on the EnSight server by scaling the 
original coordinates and scaling/adding to this a scalar for each of the x/y/z 
coordinate values.  Thus is possible to entirely swap out a model parts coordinates to 
another variable or apply displacements on the server side of EnSight.
                                                                                      First Page                  Previous Page              Next Page 1-7



 

1-8    
Element 
Representation

It is possible, for any element representation, to load the geometry as 
points+normals only.  For large datasets this can substantially reduce the amount of 
graphics processing while adequately displaying the data.

Fast Display Mode An option of "Invisible" has been added to the part choices for fast display mode.

Texture mapping The color dialog in Part mode now has a button "Edit texture...." which brings up a 
dialog that allows you to read and apply 2D textures to any part.  Many options are 
available.

Annotation New annotations are available as follows:

Dial - a round gauge that shows the value of a constant variable

Bar - a bar graph that shows the value of a constant variable

2d arrows, circles,
and rectangles

The text annotation capability between New and Edit have been consolidated and is 
consistent with the other annotation types.
Text annotations can span multiple lines.
Text annotations can use a number of True-Type fonts and has support for 
international character fonts (Windows)
While updating text annotations it is possible to have the updates occur dynamically, 
i.e.  the updates are shown in the graphics window while you type.
The default annotation font and size (used for node/element labels, the axis system 
labels, etc.) can be set as a preference.  See Edit->Preferences->Annotation

Particle Traces Massed Particle trace settings have been simplified.
Massed Particles can now have Rebound with a coefficient of restitution and 
friction.

Case Map The CaseMap computed variable has been improved to give the user the option of 
finding the closest node if a search fails practically eliminating the problem of 
obtaining Undefined values.

Timeout You can set up a maximum amount of time you are willing to wait for any server 
operation.  See Edit->Preferences->Performance

SoS It is now possible to read any file format while using the SoS. Previous versions 
required the use of a sos case file.
It is now possible to use the SoS with multiple servers even if the data is not 
decomposed.  This version of EnSight has the ability to auto-decompose datasets 
"on the fly".

Resources A resource file may be defined and specified to EnSight describing what computer 
resources are available to run the various EnSight components.  This greatly 
simplifies parallel setup.  It is also possible to use environment variables to define 
resources which makes it convenient to use with cluster management allocation 
software.
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APIs and Data Formats
Yaw/Pitch/Roll have been added to the rigid body capability of the data format and the user defined 
readers.

The user defined reader API has added the option to read data in a decomposed manner - this used during 
EnSight's auto decompose capability for parallel servers.  The API has also added a time-history capability.  
If implemented the time-history information is available as query items in the EnSight Query interaction 
area.

Variable names can now be up to 49 characters (up from 19).  In order to provide backwards compatibility 
for the command language EnSight keeps the old shorter name as well as the new longer name.  User 
defined readers, in order to have command language compatibility, should modify the variable name but 
also provide the shorter name. The user defined reader API explains this.  The only known possible 
problem with command language is if multiple queries have been created from the same variable (EnSight 
then creates a query name which is a combination of the variable name and a number) and then a query 
combine is created with these new, longer and modified names.  Users that hit this situation will have to 
modify their command files.

Compatibilities
Archives are NOT compatible between 8.0 and version 8.2

Command language is compatible between earlier 8.0 and 8.2

Since the command language is compatible context files are also compatible between 8.0 and 8.2

Some data formats have changed their default element representation (see ensight_reader_extension.map 
in your home directory or the site_preferences directory of the 8.2 install).  This can cause parts to be 
loaded in different element representations if using an older command file.  This in turn can cause a 
difference in created parts.  Should you experience this you could consider (a) changing the .map file or (b) 
setting the element representation in the command file (which would have to be done after the parts are 
loaded).

The MRU (most recently used) list is not brought forward from 8.0 to 8.2.  The number and details of the 
MRU is completely different between the two versions and it was thus deemed impractical to preserve this.

Other Components
EnLiten remains essentially unchanged in look, feel, and functionality.  Like EnSight, it does use UDILs to 
save/print images and TrueType fonts for display.

EnVe adds a user interface allowing it to be used effectively for simple video editing.  This complements 
the release of quicktime plugins for the EVO format to popular non-linear video editing applications.

Reveal (formerly Vista) adds the ability to save multiple variables from EnSight and thus you can switch 
which variables you wish to view.

Mac PDF Reader Issue
Mac Users: if you don’t want to use Preview for EnSight documentation viewing (since hyperlinks don’t 
work well), you have the following alternative options:

1. If you have xpdf on your system, and in your path:
setenv CEI_PDFREADER xpdf

2. If you have Adobe Reader on your system and want to just have EnSight use it for pdf files:

DR The distributed rendering capabilities can take advantage of the Resources 
definitions which greatly simplifies parallel distributed rendering when using the 
image compositing mode.
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setenv CEI_PDFREADER “/Applications/Adobe Reader 7.0.7/Adobe Reader 7.0.7.app”

        (Modify the string appropriately for your Adobe Reader)

3. If you have Adobe Reader on your system and want to have it be the default app for all pdf files - 
including EnSight’s Documentation:
Go to:

 “Apple” -> System Preferences -> Default Apps
and set the default app for pdf files to be the Adobe Reader.
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